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Management of sessions

Sessions and Tracks
Sessions allow you to save the settings of several devices, as well as a title and a comment. Each session 
can have one or more versions.
A session can also serve as a folder and contain other sessions that we will call Tracks. The tracks will be 
listed in the parent session. They can be automatically numbered for album creation (see in Preferences - 
Tracks).
Although their names differ, sessions and tracks are identical in every respect, and can be used as a sim-
ple hierarchy..

The list of sessions
On the left side, the list of sessions includes all the sessions you have created.
This part is divided into three tabs.

 z Sessions: The sessions you are working on.
 z Templates: Templates allow you to make groups of pre-set devices.
 z  Archived sessions. Archiving allows you to stop displaying a session in the Sessions list, while 
keeping it.

List toolbar
 z  Remove: Permanently deletes the session and all its settings.
 z  New session: Creates a new empty session.
 z  New track: Creates a track (sub-session) in the selected session.

Archiving sessions
Sessions can be archived manually or automatically after a certain time. Once archived, sessions will no 
longer appear in the list of sessions, but in the list of archived sessions. This list is accessible by clicking 
on the  tab above the session list.
To archive a session manually

 z Select the session (or the parent session if it contains tracks), then go to the Edit menu and choose 
Archive.

To unarchive a session
 z Go to the Edit menu and choose Unarchive.

Auto-cleanup
Sessions can be archived and/or deleted after a certain period of time, which you can define in Preferenc-
es - Auto-cleanup. You can also choose to archive and/or delete only the sessions you have validated.
Be careful with the automatic deletion. Check your settings carefully.
The automatic cleaning will be done when the application starts.

Import and export sessions
You can exchange your sessions with remote collaborators thanks to the import and export functions.
When importing a session, the application will display a list of all missing devices and ask you if you want 
to install them or cancel the operation.
There is no need to purchase a license as the devices will be functional during the 15-day demo period.
To export a session

 z Select it from the list, go to the File menu and choose Export Session or Export Session and Tracks.
To import a session

 z Go to the File menu and choose Import.
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Save as image or Pdf
Sessions can be exported as an image or as a PDF file, manually or automatically.
To export a session as an image or as a PDF

 z Select it in the list, go to the File menu and choose Export as Image or Export as PDF.
Set your options in Preferences - Export.
Auto-snapshot
Sessions can also be exported automatically when they are saved with the “Auto-snapshot” function.
In Preferences - Export you can choose:

• The export format, Pdf or Jpeg.
• Whether the “Auto-snapshot” function is enabled by default for new sessions.
• Whether snapshots are deleted or kept when the session is deleted.

The “Auto-snapshot” function can also be enabled or disabled in a session via the dedicated menu with 
the  icon in the title bar of the session.
When the “Auto-snapshot” function is activated, the first saving of a session will bring up a dialog asking 
you where you want to save the snapshots folder. In general, you will choose the same location as the 
mixing or mastering project.
Image resolution
NEW By default the images are exported in low resolution (72 dpi). You can increase the resolution of 

the images in order to obtain a sharper and more defined rendering.
The resolution of the images can be changed independently for the Export and Snapshot functions. To do 
this go to Preferences - Export.

 Search for sessions
To find a session go to the Edit menu and choose Find.
A search box will appear at the bottom of the session list. Use the menu to choose the search criteria, and 
click the cross to clear the filter and return to the original list.

The session editor
This is the part on the right of the session list.

Title bar
It includes specific functions for editing sessions.

 z  Display or hide the session list.
 z 100% Zoom factor for displaying sessions (increment adjustable in Preferences - Sessions).
 z 11  The number of slots defines the width of the editor for the selected session.

 Auto-snapshot menu
• Auto-snapshot enabled: Enable or disable the automatic export to image or Pdf on saving, for the 

selected session.
• Select a Folder: Choose or change the destination location of the “snapshots” folder, for the se-

lected session.
• Show snapshots: Displays the folder containing the snapshots of the selected session.
• Delete snapshots: Delete all snapshots for the selected session.
• Save snapshot Now: Saves a snapshot of the session without having to save it.

 Options menu
• Device title bars: Shows or hides the device title bars.
• Annotations: Displays or hides the “stickers” added on the devices, and which are of type “Notes” 

or “Warning”. The other stickers will remain visible.
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• Hide disabled devices: temporarily hides devices that have been disabled via their ON/OFF but-
ton.

• Auto resize view: If enabled, the application will resize the window when the zoom factor or the 
number of slots is changed.

• Version names: If enabled the version menu will allow you to name your versions. Otherwise the 
menu will only display a version number.

Infos and Validation
The  button displays an info bar with the creation date, the modification date, and a checkbox labeled 
Validation. This box allows you to mark the session as validated by you or the client. If you have automat-
ic archiving or deletion enabled, the application will be able to ignore non-validated sessions if you have 
chosen this option in Preferences - Auto-cleanup.

 Comment
The comment button is used to show or hide the comment field.
The comment field is available for each session and track.
If a track is selected, an arrow will appear to the right of the field to allow you to display the parent ses-
sion’s comment next to the track’s comment.

Title
The Title field allows you to name the session.

Version menu
The Version menu is used to create, duplicate, or delete versions.

• New version: Creates a copy of the current version.
• New empty version: Creates a new version without a device.
• Add from template: Creates a new version from a session template.
• Duplicate version: Allows to choose the version to duplicate when there are several.
• Remove version: Deletes the current version.
• Remove others: Deletes all versions except the current one.

Size of the editor
The width of the session editor is expressed in number of slots. The width of a rack is 11 slots, but you 
may need to increase the number of slots for larger devices such as a mixing console.
To change the number of slots for all sessions

 z Go to Sessions - Number of slots.
To change the number of slots only for the selected session

 z Use the menu with the <—> icon found in the title bar of the session, next to the Zoom menu.
If the maximum number of slots is not enough you can add more in Preferences - Sessions.

The session templates
Allows you to quickly create sessions from predefined templates.

Create a template
From an existing session

 z Select a session, then go to the File menu and choose Save as Template.
From scratch

 z Click on the Templates tab above the list of sessions, then click on the New Template button.
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 z Then add your devices and organize them as you see fit.
 z Name your template explicitly and save it.

Using templates
Once created, templates can be used in several ways.

 z Use the same template for all your sessions: Go to Preferences - Sessions and choose the template 
to use.
 z Use the same template for all your tracks: Go to Preferences - Tracks and choose the template to 
use.
 z Create a new session from a template: Go to the File menu and choose New session from template.
 z Create a new track from a template: Select the parent session, then go to the File menu and choose 
New Track from Template.
 z You can also add devices from a template to an existing session via the Add new device menu in the 
editor’s title bar. If the session already contains devices, you will be asked whether you want to keep 
them or delete them before adding the template devices.
 z NEW Display the Template Browser in the session (Mac: cmd-B, Win: ctrl-B), then drag a template 
into the session. The devices in the template will be inserted among the devices already present. 
Templates can also be dragged directly into the session list to create a new session or track.

Management of devices
Installation and authorization require an Internet connection.
It is highly recommended to install the devices and to take advantage of the demo period to try them. If 
you notice any errors, please contact support as soon as possible to determine if they are errors or if the 
device does not match your hardware. Manufacturers sometimes make very similar revisions which can 
easily be confused.

 Installing devices
To install a device, click on the Devices tab in the navigation bar.

 z On the right side of the window, click on Refresh List to display the available devices.
 z Select a manufacturer from the list on the left and then select a device from the list on the right.
 z Then click on Download and Install.
 z The installed devices will appear in your device list on the left side of the window.

 Device authorization
NEW Since SessionRecall 1.2 the serialization process has been greatly simplified.

 z On the right side of the window, click on the My Licenses tab.
 z Then click on Refresh List in the toolbar to load all your licenses from the website. The devices in the 
list can be installed (if not already installed) and authorized individually or all together with one click.
• If the devices you have purchased do not appear in the list, please contact us.

 Search for devices
You can search for a device by using the search field on the right side, having previously loaded the list of 
devices. This field will be very useful to find generic devices by typing the brand name and/or the model of 
the device.

The list of devices
On the left side, the list of your devices includes all the devices you have installed.
This part is divided into three tabs.

 z Installed: The installed devices.
 z Serialized: The serialized devices.
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 z  Archived devices. Archiving allows you to stop displaying a device in the lists and menus, while 
keeping it in the sessions where it was used. This function is very useful when, for example, you sell a 
device. Instead of deleting it, archive it and you will keep your settings.

NEW Since SessionRecall 1.2 devices can be renamed simply by double-clicking on their name in the 
list. This means that you can rename generic devices to your liking.
List toolbar

 z  Remove: Permanently delete a device and all its settings. It will no longer appear in the sessions 
where it was used.
 z  Import: Allows you to import custom made devices that are not available online.

Devices

Device title bar
By default the title bar shows the name of the device. In the session you can change the title of each de-
vice for a more explicit one.

 z Channel tab: Indicates the number of channels of the device. A dual-mono device with linked chan-
nels will show Stereo instead of chan 1-2. In mid-side mode the tab will show Mid-Side.
 z  Stereolink Button: Activated by default, this button syncs the controls of channels 1 and 2.
 z  ON/OFF Button: Allows you to turn off the unit when not in use.
 z  Options menu:

• Delete: Deletes the device from the session.
• Add device before: Adds a new device before.
• Add device after: Adds a new device after.
• Enabled: Enables or disables the device like the ON/OFF button.
• Copy settings: Copies the settings of the device.
• Paste settings: Pastes the settings into the device. Greyed out if the copied settings are not from 

the same device.
• Stereolink: Enables or disables the synchronization of the controls of channels 1 and 2.
• Mid/Side: Enables or disables the mid-side mode. If activated, the Stereolink will be deactivated 

and the device tab will display the mention Mid-Side.
• Side/Mid: Same as above with the channels reversed.
• Reset to Defaults: Replaces the current settings with the default settings.
• Save as Defaults: Replaces the default settings with the current settings, including stickers.
• Create and use a global setting: Creates a shared setting that can be used by all devices of the 

same model in the current session, as well as in its tracks and versions.
• Use global setting: Allows to use or not to use a global setting created for this device model.
• Restore Session Values: Replaces the current settings with the settings previously saved in the 

session.
• Restore Device Title: Restores the original device name in the title bar.

 z  NEW Presets menu: This menu will show all the presets you have saved for the device. By de-
fault this menu is hidden. Go to Preferences - Sessions to display it in all the title bars of the devices.

Default values
When a device is added to a session it loads its default values, but you will probably save time by adjust-
ing these values to your liking. To do this, simply go to the Options menu on the right of the title bar, and 
choose Save as default values.
To return to the original default values, choose Restore default values.
The default values include the state of all buttons and stickers added to the device.

Global setting
It is common for a device to be set identically on several tracks of an album, and it is for this very case that 
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the global setting was created.
A global setting is a setting that is shared and accessible to devices of the same model in the whole ses-
sion, its tracks, and all their versions.

 z Create a global setting: Set your device once, then in its Options menu choose Create and use a 
global setting.
 z Use a global setting: to use the same settings on the same device in another version or another track, 
go to the Options menu and choose Use global setting.
 z Stop using a global setting: At any time you can decide to stop using the global setting on a device. 
To do this go to the Options menu of the device and uncheck Use global setting. The device will then 
become independent and return to its previous setting.

The global setting is dynamic. If you change it on a device that uses it, all the devices using it in the ses-
sion, tracks or versions, will also be changed.
There can only be one global setting per device of the same model.
Devices using a global setting have their title bar turned blue.
The global setting is automatically deleted when it’s no longer used.

Customize buttons
Some buttons are customizable.

 z For example, you can change the text of the push buttons by clicking on the button with the Control 
key pressed.
 z You can also change the color of the LEDs linked to a push button, which is particularly useful for 
devices sold with interchangeable modules, whose LED color may vary depending on the module in-
stalled. To do this, click on the Led to be modified with the Control key held down. A contextual menu 
will appear with a choice of colors.

Warning: If you restore the default values of a device you will lose the customization.

The stickers
The “stickers” are small labels that you can add on your devices.
There are 3 types of stickers 

 z The normal and multi-purpose stickers available in several styles. 
 z The Notes which are more visible and more intended to inform a collaborator. 
 z The Warnings which are meant to warn!

The Warnings and Notes are not customizable, but they can be easily hidden so as not to interfere with the 
reading or the settings. To do this go to the Sessions menu and uncheck Device Annotations.
To add a sticker there are 2 ways

 z Click in the Options menu of the device and choose Add Sticker. The sticker will appear in the center 
of the device.
 z Click on the device with the Control key pressed, where you want to add the sticker, and choose Add 
Sticker. The Sticker will appear centered on the spot where you clicked.

To edit, delete or duplicate a Sticker
 z Click on the Sticker with the Control key held down. A pop-up menu will appear.

• Size: Set the size of the text.
• Style: Allows you to change the style of the sticker.
• Alignment: The alignment of the text in the sticker.
• Background color: The background color of the sticker.
• Text Color: The color of the text in the sticker.
• Copy style : Copy all the graphic attributes of the sticker.
• Paste style : Paste the previously copied graphic attributes.
• Duplicate : Duplicates the sticker by shifting it a few pixels.
• Delete: Deletes the sticker from the device.

To edit the text of a sticker
 z Double-click on the sticker. Edit the text and validate with the Enter or OK key.
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Arrangement of the modules in the session
Devices in Rack format will always be added vertically one after the other. You can change the order by 
dragging them or by using the arrows that appear on the left when the mouse hovers over the device.
The other devices will automatically create a row corresponding to their format, and will be arranged hori-
zontally one after the other.
The number of devices per row will depend on the type of device and the number of slots available.

 z Half-rack format devices are limited to 2 per row.
 z Third-rack format devices are limited to 3 per row.
 z Quarter-rack format devices are limited to 4 per row.
 z All other formats (500, 200, 80, Danner, Consoles,...) are limited only by the number of slots.

The automatic arrangement of the modules in the rows does not leave any empty slots, which is some-
times not suitable if you want to reproduce the position of the real modules and leave empty slots.
If you want to add modules in one row without completing it, and then add other modules of the same 
format in another row, you just need to add a Module Row Separator after the modules of the first row.
You can also add Blank Panels to fill in gaps between modules.
You can find all this in the menu Add new device - Utilities.

Highlighting of controls
NEW This function allows you to highlight some controls such as push buttons when they are on, or 

rotary knobs when they are modified (different from their default value), or not centered if their default value 
is in the center like most of the pan and gain buttons.
To highlight the modified buttons

 z Press the Space bar. The buttons will then display a colored outline that will make them easy to dis-
tinguish. Console owners will appreciate this!

To return to the initial state
 z Simply press the Space bar again.

See the settings for this function in Preferences - Controls.
 

Utilities
Utilities can be found in the Add new device menu.

Notepad
Notepad allows you to add text in a session. Unlike the comment field you can add as many modules as 
you want, where you want.

 z  Options menu:
• Delete: Deletes the Notepad from the session.
• Title Bar: Inherited Visibility will show or hide the title bar with the devices title bar. Otherwise 

choose Always visible or Always hidden.

Photo module
The Photo Module allows you to add one photo per module, and as many modules as you want per ses-
sion. Once added, the photos can be cropped, resized, rotated, and this in a non-destructive way.

 z Import button: Imports a JPG or PNG image into the selected tab.
 z Remove Button: Deletes the image in the selected tab.
 z  Options menu:

• Delete: Deletes the Photo Module from the session.
• Import Photo: Imports a JPG or PNG image into the selected tab.
• Remove this photo: Deletes the image in the selected tab.
• Reset rotation: Removes the rotation applied to the image.
• Reset position (center): Resets the image to the center position.
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• Add Sticker: Adds a new sticker to the selected tab.
• NEW Format: allows you to change the size of the photo module in order to integrate it in a 

row of modules for example. The default “rack” format is resizable in height, unlike the other for-
mats which have predefined sizes.

• NEW Take Photo: if an iOS device is detected, this feature will allow you to trigger the camera 
from SessionRecall. The photo will be added directly to the photo module. Click with the control 
key pressed, or with the right click, on a photo module or on an empty slot to bring up the contex-
tual menu. For the moment this function is only available on MacOS.

Meter module
Allows you to create a row containing one or more meters, whose style and number of segments are ad-
justable. The meters can save a defined value or a range of values.

 z  Options menu:
• Delete: Deletes the Meter Module from the session.
• Horizontal: Displays the meters horizontally.
• Vertical: Displays the meters vertically.
• Number of slots: Determines the width of the module.
• Meter Types: Determines the style and number of segments.
• Add Channel: Adds a new channel to the last position.
• Channels: Allows you to define the number of channels in the module.
• Remove channel: Deletes a meter identified by the channel title.

Module row separator
Placed between 2 rows of modules of the same type, it will prevent the modules from grouping automati-
cally. The modules in the row after will not be able to move to the row before.

 z  Options menu:
• Delete: Deletes the Module row separator from the session.

Blank panels
To fill the empty slots in the rows of modules.

 z  Menu Options :
• Delete: Deletes the Blank panel from the session.
• Add Sticker: Adds a new sticker to the empty panel.

Presets
NEW Presets can be used with all devices.

If you have not displayed the Presets menu (Preferences - Sessions) in the title bar of the devices, you will 
be able to access the Presets manager via the option menu of each device.
By displaying the Presets menu in the title bar, you will also have direct access to all your saved presets.

 z To save a preset, go to the  Presets menu (if displayed) or the  Options menu, and choose Save 
Preset.
 z To update a preset used by a device, go to the  Presets menu (if displayed) or the  Options 
menu, and choose Update Preset.
 z To manage your presets, go to the  Presets menu (if displayed) or the  Options menu, and 
choose Preset Manager.



SESSIONRECALL 11

Preset Manager

 z 1. The title bar: displays the full name of the device, as well as the name displayed in its title bar if you 
have modified it.
 z 2. The list of preset banks.
 z 3. The list of tags.
 z 4. The list of presets.
 z 5. Export (arrow down) or import (arrow up) a complete bank of presets.
 z 6. Delete or Add a preset bank.
 z 7. Tag options menu: allows you to create different groups of tags depending on the devices for 
which the presets are intended. For example you could create a group of tags for your synthesizers, 
another one for equalizers, etc. The tag groups will be available for all devices.
 z 8. Delete or Add a tag to the displayed group.
 z 9. Export or Import a preset.
 z 10. Display the search field.
 z 11. Delete a preset.
 z 12. Displays a panel on the right for editing the bank and tags of the selected preset.
 z 13. Panel for editing the bank and tags of a preset.
 z 14. Apply the selected preset to the device.
 z 15. Close the preset manager.

Advanced

Backups
To backup your SessionRecall data, you must include the following folder:
- User / Documents / SessionRecall
If you have a problem, restore this folder to its original location (Quit SessionRecall first).
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Using iCloud Drive (Mac)
On the Mac you can simply sync your Documents folder where the SessionRecall database is installed by 
default, by enabling iCloud Drive in System Preferences - iCloud.

Using OneDrive Drive (Windows)
On Windows you can move the database to Microsoft’s OneDrive.

Using another Cloud or an external drive
If you don’t want to use one of these two services, or if you don’t want to clone your Documents folder on 
a Cloud, you can move the SessionRecall database to any cloned folder like Dropbox for example, or to an 
external drive.
If you move the database to an external drive in order to work on another computer, you will need to copy 
the file: user / Documents / SessionRecall / UserPreferences.db to the same location on the other comput-
er. This will allow SessionRecall to find the location of its database on the external drive.

Relocate the database
Go to Preferences - Database.
SessionRecall shows you the path to the database file.
To move the database

 z Click Change database location.
 z Choose a destination folder.
 z Save the Preferences.

To get it back to its original location
 z Click Move back to default Location.
 z Save the Preferences.

Database not found? Connect to another database file.
 z Click Reconnect to database.
 z Select the database file (SessionRecall.db).
 z Save the Preferences.

Multiple computers with the same devices
You can use your username on several computers simultaneously and share serial numbers.

Multi-users?
Not really. You can work with several users on the same database via a Cloud, or by installing it on a net-
work drive, but never simultaneously, at the risk of permanently corrupting the database.

Migrate to a new computer
Want to recover your session data, devices, licenses, and preferences?

 z Copy the following folder from your old computer: 
- Utilisateur / Documents / SessionRecall
 z On the new computer, install SessionRecall if you have not already done so.
 z If SessionRecall is running, quit the application.
 z Put the SessionRecall folder in User / Documents (replace if it exists).

This procedure also allows you to migrate from a Mac to a PC and vice versa.

Uninstall SessionRecall
 z Delete the SessionRecall application from your Applications folder.
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 z Delete the following folder: 
User / Documents / SessionRecall

Keyboard shortcuts
You can add your own shortcuts to trigger different actions.
To do this, go to the menu bar, Window - Keyboard Shortcuts.

 z Click on Add to create a new keyboard shortcut.
 z Type a character on your keyboard to be assigned to the keyboard shortcut selected in the list.
 z Add an Action to trigger.
 z Adjust the parameters of the action if there are any.
 z Save and voilà.

Troubleshooting

Device authorization
 z If the first device refuses your serial number, make sure your username is spelled correctly and is the 
same as the one you used on the website.
 z If you have already serialized other devices, make sure the name of the installed device matches the 
one you purchased.
 z If the username is correct and the device matches, an anti-virus or firewall may be blocking internet 
access to the application. Add SessionRecall to your anti-virus or firewall’s list of trusted applications.
 z Your already serialized devices appear in demo mode: Check that your username is still present in 
Preferences - General. Have you assigned a serial number to each of your devices in the application?
 z If it still doesn’t work, make sure your internet connection is active and that the session-recall.com 
site is online.
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While a software is often the brainchild of one or more developers, 
much of its evolution is due to the experience of its users.

Created in 2018, SessionRecall now has about 2000 users in 70 
countries around the globe. 

Thanks to you, and may the adventure continue!
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